web関連tips備忘録

| 1 |

array_merge() のphp4とphp5の違い


php4→php5に変更したところ、array_merge() を使用している部分でエラーが出るようになった。
調べてみると
「array_merge() の動作は PHP 5 で変更されました。PHP 4 とは異なり、 array_merge() は、array 型のパラメータのみを受け取るようになりました。」
とあったので、
エラー発生箇所の
$quizs =array_merge( $quizs,$qindex );

$quizs =array_merge( (array)$quizs,(array)$qindex );
に変更することによってエラーが解消した。

その他 2011-06-16(木) 08:37:25 - kei - TrackBacks
| 1 |
LINK